Off Road Vehicles banner

1 - 6 of 6 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter #1
Has anyone out there evef had to replace the speed sensor in the rear end mine went out causing all my light to come on on the dash the dealer wants $200 to replace it how hard is it to do and where is the part actually located.
Thanks
 

·
Registered
Joined
·
1,057 Posts
Should take about 15 minutes.

It screws into the top of the differential in the center of the axle housing, up on top where the brake-lines are bolted down..

Just disconnect the wire, unscrew the nut from the stud. lift the lines off the stud, then unscrew the stud out of the axle housing. Pull out the sensor and replace.

Screw the stud back in, replace the lines, and screw the nut back down.

However, road-salt and other sources of rust could complicate that a bit...
 

·
Registered
Joined
·
1,057 Posts
True, but you'll get it if you live within a mile or two of the coast. Atleast you do here in CA. People that live (literally) on the coast just watch their cars rust.

We get lots of heavy fogs, and they will pick up some salt, and the breakers will toss salt into the air. Often see a white residue from the salt on cars that have been parked for a few days near the ocean.

I'm way up in the hills, about 30 minutes from the coast, so it's no worries for me.
 

·
Registered
Joined
·
333 Posts
Discussion Starter #5
Thank you woody finally got around to replacing today it went just like you said and after disconnecting the battery to reset computer all the lights went out and the speedo is working right again.
Thanks again
 
1 - 6 of 6 Posts
Top