Off Road Vehicles banner

1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
my truck has almost 43,000 miles, it is a 318 1999 ram 4x4. it recently began to have a whine that could be heard in the radio. the lights arent as bright as they chould be at idle but when you give it gas they brighten up. I have had autozone check the battery and the alt. they said everything was o.k. the truck still runs good when driving around but it almost stalls in park after giving it some gas.
any advice would be appreciated.
 

·
Registered
Joined
·
1,611 Posts
Might be the voltage regulator.
 

·
Registered
Joined
·
246 Posts
the voltage reulater is internal on the new altniators for the new dodges. sounds like your maybe going out. easy test ... buy an alt. put in on and see if its still there. if it is then swith back box it up and take it back. but it does sound like its in the alt. like the turn on speed or something. try a new one and find out its the best way to do it.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #5
thanks I will have to try that. only bad thing is that I will have to pay the core up front. but it is worth a try.
 

·
Registered
Joined
·
3,036 Posts
On 2002-02-21 05:40, Fjthis wrote:
the voltage reulater is internal on the new altniators for the new dodges. sounds like your maybe going out. easy test ... buy an alt. put in on and see if its still there. if it is then swith back box it up and take it back. but it does sound like its in the alt. like the turn on speed or something. try a new one and find out its the best way to do it.

and alot of times they wont take back electrical items like that also if that isnt the problem.
 
1 - 6 of 6 Posts
Top