Off Road Vehicles banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3,385 Posts
Discussion Starter #1
ok, I have a problem with my truck. The lower control arm Cam adjustment washers do not fit tightly in the adjustment "slot" how the hell can I fix this? its anoying the hell out of me because I can tighten the hell out of the cam bolts, but since the washer has 1/8" or more slop from front to back It still moves if I hit the brakes hard enough, it slides back and forth. I really hope I am not screwed as I need to align the truck, but it want stay put in this current state. What can I do?
 

·
Premium Member
Joined
·
9,227 Posts
the "U" retianers are only welded in a couple spots. sounds like my truck, where the ends of the "U" have simply bent fore/aft. Try to move them back tight to the cam. jsut make sure to make both driver and passenger the same.

i have not tried to bend mine yet, i jsut tighten the crap out of the bolts.
 

·
Registered
Joined
·
2,605 Posts
mine somehow ride over those spots. when i try to crank down on the nuts, it moves the head of the washer over the raised part. not sure what to do.
 

·
Registered
Joined
·
3,818 Posts
On 2005-12-13 20:43, The Boss wrote:
the "U" retianers are only welded in a couple spots. sounds like my truck, where the ends of the "U" have simply bent fore/aft. Try to move them back tight to the cam. jsut make sure to make both driver and passenger the same.

i have not tried to bend mine yet, i jsut tighten the crap out of the bolts.



Same thing happened to mine. I just beat the ends of the Us back in place and tacked them. That was a couple years ago, and they still haven't budged.
 
1 - 4 of 4 Posts
Top