1. Sorry for the initial hiccups after launch. Everyone should be able to login now.

    Welcome to the new Pavement Sucks!

    If you are having a problem logging in, try RESETTING YOUR PASSWORD HERE

Seat belt light stays on

Discussion in 'Dodge 4x4' started by lavs4x4, Jun 6, 2006.

  1. lavs4x4

    lavs4x4
    Expand Collapse
    New Member

    219
    0
    0
    Light stays on even when I have my seat belt on whats up with that. Is there a sensor or something in the buckle that is screwed up? I don't like lights on my dash what to I do.
     

  2. JustRamIt

    JustRamIt
    Expand Collapse
    New Member

    1,681
    0
    0
    Reach under your seat and there should be a little one wire plug. Unplug it and you'll never have a light again :bigthumb:
     

  3. RootBreaker

    RootBreaker
    Expand Collapse
    New Member

    3,280
    0
    0
    I have the same thing on my 78 chevy... i just dont pay attention.. until inspection.. then unplug the bulb.... :rotfl:



    boy gotta fix that... with eldo calipers in the back I want to know when my brakes are on.... I dont have a obd ii plug so cant fail inspection for that...
     
  4. lavs4x4

    lavs4x4
    Expand Collapse
    New Member

    219
    0
    0
    I will look for the plug tonight but what is causing this and is there a way to fix it correctly?
     
  5. RootBreaker

    RootBreaker
    Expand Collapse
    New Member

    3,280
    0
    0
    i dont know if this will help you with your dodge... but if you think about it... it is 1 wire.. thus voltage has to go through it.. and when you put the metal belt into the lock.. it must complete the circuit turning the light on... so if your light is on... you may have a short....



    i know my problem is in the seat belt... I think that will be my problem.. where the belt rolls up.. and is stored.... :silly:
     
  6. mopar

    mopar
    Expand Collapse
    New Member

    5,781
    0
    0
    i had the same problem in my 98 .... and now the light starts to flicker in my 02 ..... i got to find the plug



    aparently its a common thing
     
  7. rickrok

    rickrok
    Expand Collapse
    New Member

    87
    0
    0
    My 01 does the same thing and it's annoying having that dash lite on. Took it to the dealer once and they said everything was fine. :fu: It's gotta be some kind of switch inside the buckle itself that's not making contact when buckled. I can actually get the light to go on & off while going down the road. So next trip to the dealer I'll take the service manager for a ride and show him this ain't right. :loser:
     
  8. Hometheaterman

    Hometheaterman
    Expand Collapse
    New Member

    2,408
    0
    0
    Mine never comes on except for a split second when I start it up. Is this normal or is mine disconnected already?
     
  9. mopar

    mopar
    Expand Collapse
    New Member

    5,781
    0
    0
    mines tha same way rick, i am just going to un plug it, the belt will still act the same
     
  10. pg318

    pg318
    Expand Collapse
    New Member

    56
    0
    0
    On 2nd gen quadcabs, the connector has two pins, and presumably completes the circuit via grounding through the seat frame, as there's a solenoid which holds off the locking pawl on the reel inside the seat, so if you unplug the connector, the reels lock up.

    There's also a switch (in the reel, not the buckle) which opens when the belt is pulled out, to turn off the beep during the startup, on mine the warning light doesn't stay lit if you leave the belt off. I think the issue is water in the loom under the seats, at least when I took my carpets out to dry (I've done that three times now :cuss: ) it goes away until they get wet again.
     
  11. halo 216

    halo 216
    Expand Collapse
    New Member

    1,120
    0
    0
    Yeah i had this happen to my car? maybe my truck? I cleaned the inside with alcohol and acotton swap and cleaned the buckle itself too. SOmetimes just a little dirty and needs cleaned.
     
  12. lavs4x4

    lavs4x4
    Expand Collapse
    New Member

    219
    0
    0
    thanks guys the light has gone out on its own. I hopped in the other day and no light, so, we'll see if it stays off.



    thanks again for the info
     

Share This Page