1. Sorry for the initial hiccups after launch. Everyone should be able to login now.

    Welcome to the new Pavement Sucks!

    If you are having a problem logging in, try RESETTING YOUR PASSWORD HERE

Catalytic converter glowing red!!!

Discussion in 'Engine/Drivetrain/Suspension' started by King Nothing, Oct 8, 2004.


  1. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Just put a brand new catalytic converter in the truck. Took it for a test drive and when I got back the converter was glowing red. I realized that I forgot to put the oxygen sensor back in when I put it back together. could this have caused the truck to run like sh1t and the converter to glow red or do I have another problem??



    edit: also do you think I might have ruined the converter??
     

  2. BigWillieStyle_21

    BigWillieStyle_21
    Expand Collapse
    New Member

    3,258
    0
    0
    Is it flowing the correct direction (On backwards???)



    Thats odd, I don't think the 02 not being in would do that...





    BIG
     

  3. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Yes, It was a whole a$$embly from the manifolds back 2 feet past the converter. no way to put it on backwards. I thought maybe with the o2 sensor out the computer might have been dumping too much fuel in and that might have cause the converter to glow
     
  4. Mr Joe

    Mr Joe
    Expand Collapse
    New Member

    8,327
    0
    0
    I could see the air/fuel mixture being messed up by the O2 sensor missing. That could cause the cherry red convertor. I have also seen clogged convertors do that, but with yours being new I doubt it. Unless there was trash in it before you installed it.



    :baby:
     
  5. bowtie_guy

    bowtie_guy
    Expand Collapse
    New Member

    1,708
    0
    0
    I had that problem. I removed the air box and it fixed it. After lookin around the air box I discovered it had a clogged inlet so I figure it was starving for air.



    Check the intake system
     
  6. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Did a little bit of research and it seems like its the o2 sensor not being in there. Lots of places I ran across on the net say that unburned fuel causes the converter to glow red hot. with the oxygen sensor reading outside air (21 percent oxygen) the computer would be dumping fuel into the cylinders to try to burn off that extra oxygen. Ill put the o2 sensor in tomorrow and see if it helps. I doubt its anything else since Its never done it before
     
  7. Archer

    Archer
    Expand Collapse
    New Member

    4,502
    0
    0
    Was the cat clogged before you replaced it, could have some of the inards of the old one flowed back into the muffler and caused plugging?
     
  8. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Muffler????? whats that?? :naughty: My exhaust consists of a brand new catalytic converter, 24 inches of pipe and a turndown
     
  9. Tim

    Tim
    Expand Collapse
    New Member

    2,189
    0
    0
    Late, or lean......
     
  10. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Putting the o2 sensor back in solved the problem :wall:
     
  11. Tim

    Tim
    Expand Collapse
    New Member

    2,189
    0
    0
    Lean. :bigthumb:
     
  12. KB440

    KB440
    Expand Collapse
    New Member

    3,260
    0
    0
    Jay what kind on cat did you back on? I just finished mine today to, what a huge difference.
     
  13. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Actually Tim, I think it was running rich. the oxygen sensor was reading from the outside environment, meaning it was reading 21% oxygen instead of 1% in the exhause. The computer would read this as lean and dump more fuel into the cylinders
     
  14. King Nothing

    King Nothing
    Expand Collapse
    New Member

    5,579
    0
    0
    Cheap replacement cat from advance auto parts
     
  15. goodoledodge

    goodoledodge
    Expand Collapse
    New Member

    740
    0
    0
    how cheap we talken here i need one fer my 96 with OBU2 on it
     
  16. KB440

    KB440
    Expand Collapse
    New Member

    3,260
    0
    0
    I got mine off E-bay car-sound hi-flow 94037 for $85 shipped. Arrived 2-days later, sounds great too.
     
  17. goodoledodge

    goodoledodge
    Expand Collapse
    New Member

    740
    0
    0
    and no light of any sort has cum on? is it still the 2 inlet singale outlet like the factory one? if it is ima be all over that dude
     
  18. KB440

    KB440
    Expand Collapse
    New Member

    3,260
    0
    0
    2 in 1 out, no light.



    here's a pic



    AS Usual I can't post a pic!!!
     
  19. goodoledodge

    goodoledodge
    Expand Collapse
    New Member

    740
    0
    0
    sweet!!!!!!!!!!!!!! :D:
     
  20. KB440

    KB440
    Expand Collapse
    New Member

    3,260
    0
    0
    here you go, I cut the old off and welded this one in.

    [img=500x375]http://memimage.cardomain.net/member_img_a/486454_38_full.jpg[/img]
     

Share This Page