Jacobs Ignition Installation

Jacobs Ignition Installation

REQUIRED TOOLS
MATERIALS
(Check manual for types, amounts and applicability)
TIME
Drill and bits
Allen Set
Slotted and Phillips Screwdrivers
DVM
Wire Strippers
Wire Crimpers
Plug Gap Tool
Spark Plug Socket
Trim Rivets
Misc Hardware not provided with kit
New Copper or Brass ONLY Cap and Rotor
New Spark Plugs
3 Hours

By jprtroy

Choosing a aftermarket ignition system was not as easy as I thought it would be, I finally settled on the Jacobs system. (I guess the millions they poured into their propaganda worked). After a phone call to Jacobs to order my system, the technical support person I spoke with recommended I go with the "Off-road Ultra team" He took information about my truck, (eng. Size, make, model etc.) then I ordered it.

When the ignition kit arrived via UPS, I immediately opened it. I didn't see my "off-road ultra team" computer, I saw a "Pro street" computer! I expected to see an Off-road computer. Didn't matter as the computer is the same between them, only the accessories change the names. So with that in mind, I went about the installation.

I thought that choosing a system was hard, Trying to locate a place for the computer was a bit taxing. It requires a space 8.5" X 5" for flat mounting, or 2"X 5" for vertical mounting. Flat space under my hood is gone, as I have dual batteries, a dual battery management system, a small air compressor (used for bike tires) and numerous 12vdc relays to control various lights & accessories. Under my hood is pretty busy. I choose to mount the computer vertically (only requires 2 inches this way)

on the drivers side just next to the brake booster (there was a little patch of metal showing so I took it!)

The instructions stated that a L-bracket was "included" but I found no such item in the box. I had some aluminum angle, and thought I can use this. I carefully marked the aluminum and drilled two holes (for 10X32 x 2" SS hardware) to mount the computer to the aluminum, then utilizing two holes already present on the fender well, made a template from a piece of paper (torn from a sheet) big enough to cover the fender well holes, placed the piece of paper over the two holes and with my greasy finger, rubbed the paper into the holes, thus giving me a greasy imprint of the holes. I used that imprint to drill the holes needed to mount the aluminum angle to the fender well.

Next came mounting the computer to the truck. I had to remove the fender well liners, but before I did this, I needed a way to re-attach the liners. I contacted Jason B. and he told me about "Trim Rivets"

Available at Kragen's. On my way from work one night I stopped in and bought some. (thanks again Jason) After removing the liners, I bolted the computer down solid.

The wire harness that's on the Jacobs computer is plenty long enough, and I ran it along the firewall (behind brake booster, over the cap & rotor to the passenger side fender well) I added it to the fat wire loom already present from the many lights I've mounted, a few cable ties and it was home.

My particular kit came "plug & play" I didn't have to cut or splice any wires.

Next came mounting the "Torquer coil" and secondary coil. The Torquer coil is pretty big and heavy, and being a Amateur radio operator, I didn't want it to affect any of my radios (stereo included!) so I mounted it as far from the firewall (and stereo antenna) as the coil wire would allow. This happened to be on the passenger side fender well, low, next to the shock tower

and the secondary coil is just below it, (black thing about 5" long) To place it, I stretched the coil wire (opposite from distributor) to an open area, and placed the coil there, checked for ample play in the coil wire (wouldn't want it getting pulled off in articulation now would I) then marked the area for drilling.

To mount the secondary coil, I used a hole already present in the fender. Using a SS cap screw I mounted it firmly to the fender. The secondary coil can be seen just below the Torquer coil. I'll explain what the secondary coil's function is later.

Now that everything from the kit is mounted (except for the "up-hill power module) it was time for the new cap & rotor. Jacobs recommends using a cap that has solid brass or copper towers. I guess the other caps will be burned up? Don't know this for sure. I went to a local auto parts and bought a Borg Warner C274 cap, and D223 rotor. I also bought new plugs (auto-lite).

This was my first time changing the cap & rotor. What a PTA! I managed to locate the screws, after finding a suitable position up, under my hood, sitting on my second battery, left foot down on the frame, and laying down across the intake!

WOW it really is back there! A few course words later the cap was loose! I then removed the plug wires from the plugs, and the all the cable ties holding them. NOTE: Before you unplug all the plug wires, be sure you know the firing order! I had my shop manual handy, so I paid little attention to this when removing the cap & wires.

With the old cap & wires out, I got my camp table out and used it to match up spark plug wire lengths

of the new kit to the old wires. The new plug wires come a little longer that needed (not more than say '") and as a close match was found, I numbered the new plug wire with a sharpie Marker. I also noticed that because the space the cap sits in, the wires were facing particular directions

Basically sending wires for cylinders 2,4,6, & 8 out one side and the odd numbers out the other side. I match the pattern as closely as the wires would allow.

With the new cap & rotor in place and snugged down , I fished the plug wires to their respective plugs. I then replaced the old plugs with the new plugs, gapped last night to a recommended .054, (.020 over stock of .035) and then plugged in the new plug wires.

At this point it was well past beer 30! I took a break. With everything mounted that was to be mounted, it was time to wire up everything. The Torquer coil has a wire harness attached to it that connects it via two watertight connectors, to the main computer. And a green wire, that connects the secondary coil to the Torquer coil. (there are black GND wires on both coils that go to body ground as well) All connections printed were connected to their correct places. Including a RED wire that requires 12v keyed on connection. I made this connection at a point inside my fuse block.* The last connection I made was to connect the main power leads (Red & Black wires) to the main battery. The power wires came with these goofy brass things, used to slip into the battery connector with out removing it, thus clearing your radio stations. I cut these things off and installed normal ring terminals!

Otay! Everything was connected, plugged in, mounted. Only thing left was to double check everything! Then install the 25a fuse in the main power line. Operation of the unit is indicated with 2 LED's one for input and one for output. Both are to be on when everything is operating normally and the engine is running.

I mentioned "Plug & play" earlier, well here's how everything works. The only connection to my trucks ignition system is at the stock coil. The secondary coil connects to the stock coil through a plug wire which is labeled, and receives a signal from it (the spark) it then sends that spark signal to the main computer, which then does it's magic and sends it to the Torquer coil, (via the wiring harness) the Torquer coil then amplifies the signal, and sends a high energy spark to the distributor, causing motor to run.

To return to normal, stock ignition, I just need to move the coil wire from the Torquer coil back to the stock coil, (should something go wrong) Not sure how well my motor will run with spark plugs gapped at .060 though! Could be an exciting ride.

Problems I encountered: While my motor was warm it would start, but didn't seem to start like it should. When cold, forget it! It wouldn't start at all ! This was not right! I was getting ready to kick some things! A call to Jacobs quickly fixed the issue of cold starts (starting in general!) Turns out that some applications don't require a certain wire connection. (my only footnote) I was asked if I connected the RED wire to a 12v keyed on source, "I did" I told him. He asked that I try disconnecting that red wire from the 12v keyed source and try starting the motor again. I did as requested and my 360ci roared to life! It started like it was supposed to! Apparently the red wire connected to 12v keyed on source is used to start the Jacobs system, but the system has a "auto on" function and with both hooked up, it got confused.

Now, I can "screech" a tire from a stop! (lockers not yet mounted!) My truck has never been able to do that. ( I wasn't on the paint either!) Now I get to see if my gas mileage improves. (as I've logged my gas usage for the last five years, every fill up, I have real good base line to measure it by.